We are experiencing DB failures
Incident Report for SourceClear
Resolved
Issue is fixed and we apologies for the inconvenience
Posted Oct 05, 2017 - 01:24 PDT
Investigating
We are experiencing DB failures and are triaging the event now
Posted Oct 05, 2017 - 00:43 PDT